ETK-2026-3553Zero's internal tracking ID, independent of the CVE number.
waiting for further signalsZero needs more public information before it can validate it.description
Parse Server instances with beforeSave triggers can be terminated by a crafted object update, disrupting service until the process restarts. Exposure requires an affected class to accept the relevant client update; this may include unauthenticated access through a client key or a signed-in user updating their own user record.
mitigation
Upgrade the npm parse-server package to 8.6.121 or 9.11.1-alpha.1. Until upgrade, apply requestKeywordDenylist rules to reject dot-notation updates beneath non-object fields on classes with beforeSave triggers, or remove those triggers.
fixed in 9.11.1-alpha.1, 8.6.121
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-11-04 21:14Zghsa: trigger signal, started the run
this entry in the feed
GET /api/v1/feed/ETK-2026-3553
{ "etk_id": "ETK-2026-3553", "cve_id": null, "display_id": "ETK-2026-3553", "ghsa_id": "GHSA-2rxj-6v32-2v6j", "euvd_id": null, "status": "published", "anchor_state": "awaiting_cve", "title": "Denial of service in Parse Server beforeSave trigger handling", "summary": "Parse Server instances with `beforeSave` triggers can be terminated by a crafted object update, disrupting service until the process restarts. Exposure requires an affected class to accept the relevant client update; this may include unauthenticated access through a client key or a signed-in user updating their own user record.", "mitigation": "Upgrade the npm `parse-server` package to 8.6.121 or 9.11.1-alpha.1. Until upgrade, apply `requestKeywordDenylist` rules to reject dot-notation updates beneath non-object fields on classes with `beforeSave` triggers, or remove those triggers.", "vendor": "npm", "product": "parse-server", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 9.0.0, < 9.11.1-alpha.1" ], "ecosystem": "npm", "fixed_versions": [ "9.11.1-alpha.1" ], "package_name": "parse-server", "purl": "pkg:npm/parse-server" }, { "affected_notes": [], "affected_ranges": [ "<= 8.6.120" ], "ecosystem": "npm", "fixed_versions": [ "8.6.121" ], "package_name": "parse-server", "purl": "pkg:npm/parse-server" } ], "cwes": [ 248 ], "cvss_score": 8.2, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 13.30574925, "t0_at": null, "signals": { "trigger_signal": { "at": "2026-11-04T21:14:32+00:00", "days": -0.1321451090972222, "is_lower_bound": true, "measured_at": "2026-11-05T00:24:49.439581+00:00", "url": "https://github.com/parse-community/parse-server/security/advisories/GHSA-2rxj-6v32-2v6j" } } }
published 2026-11-04 23:19Z
last change 2026-11-05 00:05Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.