ETK-2026-3507Zero's internal tracking ID, independent of the CVE number.
waiting for further signalsZero needs more public information before it can validate it.description
Active Support versions before 8.0.5.2 and versions from 8.1 before 8.1.4.1 are affected. An unauthenticated client may be able to cause a server-process crash and sustained denial of service when an application exposes Action Cable to untrusted clients, or otherwise supplies untrusted values to safe_constantize.
mitigation
Upgrade activesupport to 8.0.5.2 or 8.1.4.1, as appropriate. Until upgrading, disable the Action Cable mount point if unused, or require authentication for Action Cable connections to reduce exposure.
fixed in 8.1.4.1, 8.0.5.2
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-11-04 03:02Zghsa: trigger signal, started the run
this entry in the feed
GET /api/v1/feed/ETK-2026-3507
{ "etk_id": "ETK-2026-3507", "cve_id": null, "display_id": "ETK-2026-3507", "ghsa_id": "GHSA-8474-xrp6-wh69", "euvd_id": null, "status": "published", "anchor_state": "awaiting_cve", "title": "Regular expression injection in Active Support safe_constantize", "summary": "Active Support versions before 8.0.5.2 and versions from 8.1 before 8.1.4.1 are affected. An unauthenticated client may be able to cause a server-process crash and sustained denial of service when an application exposes Action Cable to untrusted clients, or otherwise supplies untrusted values to safe_constantize.", "mitigation": "Upgrade activesupport to 8.0.5.2 or 8.1.4.1, as appropriate. Until upgrading, disable the Action Cable mount point if unused, or require authentication for Action Cable connections to reduce exposure.", "vendor": "rubygems", "product": "rubygems:activesupport", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 8.1, < 8.1.4.1" ], "ecosystem": "rubygems", "fixed_versions": [ "8.1.4.1" ], "package_name": "activesupport", "purl": "pkg:gem/activesupport" }, { "affected_notes": [], "affected_ranges": [ "< 8.0.5.2" ], "ecosystem": "rubygems", "fixed_versions": [ "8.0.5.2" ], "package_name": "activesupport", "purl": "pkg:gem/activesupport" } ], "cwes": [ 74 ], "cvss_score": 7.5, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 18.635713133333333, "t0_at": null, "signals": { "trigger_signal": { "at": "2026-11-04T03:02:04+00:00", "days": -0.5860399209606482, "is_lower_bound": true, "measured_at": "2026-11-04T17:05:57.969188+00:00", "url": "https://github.com/rails/rails/security/advisories/GHSA-8474-xrp6-wh69" } } }
published 2026-11-04 14:25Z
last change 2026-11-04 17:01Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.