ETK-2026-3144Zero's internal tracking ID, independent of the CVE number.
waiting for further signalsZero needs more public information before it can validate it.description
Applications embedding postrust-proxy's saas_router are affected by authorization and domain-verification flaws. A tenant with an API key may gain broader access within its tenant, access internal services through domain verification, or interfere with domain and certificate handling; exploitation requires access to the embedded multi-tenant API.
mitigation
Upgrade postrust-proxy to version 1.0.0. Until upgraded, disable or restrict access to saas_router and its domain-verification and certificate-upload functions.
fixed in 1.0.0
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-30 19:03Zghsa: trigger signal, started the run
- 2026-10-30 19:03Z
this entry in the feed
GET /api/v1/feed/ETK-2026-3144
{ "etk_id": "ETK-2026-3144", "cve_id": null, "display_id": "ETK-2026-3144", "ghsa_id": "GHSA-7vx4-vvv8-hr5x", "euvd_id": null, "status": "published", "anchor_state": "awaiting_cve", "title": "Authorization and domain verification flaws in postrust-proxy", "summary": "Applications embedding postrust-proxy's saas_router are affected by authorization and domain-verification flaws. A tenant with an API key may gain broader access within its tenant, access internal services through domain verification, or interfere with domain and certificate handling; exploitation requires access to the embedded multi-tenant API.", "mitigation": "Upgrade postrust-proxy to version 1.0.0. Until upgraded, disable or restrict access to saas_router and its domain-verification and certificate-upload functions.", "vendor": "rust", "product": "rust:postrust-proxy", "affected": [ { "affected_notes": [], "affected_ranges": [ "< 1.0.0" ], "ecosystem": "rust", "fixed_versions": [ "1.0.0" ], "package_name": "postrust-proxy", "purl": "pkg:cargo/postrust-proxy" } ], "cwes": [ 178 ], "cvss_score": 8.5, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 14.686544716666667, "t0_at": null, "signals": { "public_poc": { "at": "2026-10-30T19:03:54+00:00", "days": -0.6001402561111111, "is_lower_bound": true, "measured_at": "2026-10-31T09:28:06.195374+00:00", "url": "https://github.com/postrust/postrust/security/advisories/GHSA-7vx4-vvv8-hr5x" }, "trigger_signal": { "at": "2026-10-30T19:03:54+00:00", "days": -0.6001402561111111, "is_lower_bound": true, "measured_at": "2026-10-31T09:28:06.195374+00:00", "url": "https://github.com/postrust/postrust/security/advisories/GHSA-7vx4-vvv8-hr5x" } } }
published 2026-10-31 04:59Z
last change 2026-10-31 09:10Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.