ETK-2026-3143Zero's internal tracking ID, independent of the CVE number.
validatedZero produced an exploit or a check.description
Postrust deployments using affected postrust-core, postrust-server, or postrust-worker releases can exhaust a server thread's stack while parsing deeply nested query expressions. A network-reachable client can cause the API process or execution environment to terminate, resulting in denial of service, without needing a token.
mitigation
Upgrade postrust-core and postrust-server to 2.4.1, and postrust-worker to 1.0.1. Until upgrades are complete, configure the proxy or gateway to reject query strings with more than 64 opening parentheses, including percent-encoded forms.
fixed in 2.4.1, 1.0.1
outcome
Check only, differential: the check fires on the vulnerable build and is silent on the patched one.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-30 18:28Zghsa: trigger signal, started the run
this entry in the feed
GET /api/v1/feed/ETK-2026-3143
{ "etk_id": "ETK-2026-3143", "cve_id": null, "display_id": "ETK-2026-3143", "ghsa_id": "GHSA-cx7m-cfcg-xpp8", "euvd_id": null, "status": "published", "anchor_state": "awaiting_cve", "title": "Uncontrolled recursion in Postrust query parsing", "summary": "Postrust deployments using affected postrust-core, postrust-server, or postrust-worker releases can exhaust a server thread's stack while parsing deeply nested query expressions. A network-reachable client can cause the API process or execution environment to terminate, resulting in denial of service, without needing a token.", "mitigation": "Upgrade postrust-core and postrust-server to 2.4.1, and postrust-worker to 1.0.1. Until upgrades are complete, configure the proxy or gateway to reject query strings with more than 64 opening parentheses, including percent-encoded forms.", "vendor": "rust", "product": "rust:postrust-core", "affected": [ { "affected_notes": [], "affected_ranges": [ "<= 2.4.0" ], "ecosystem": "rust", "fixed_versions": [ "2.4.1" ], "package_name": "postrust-core", "purl": "pkg:cargo/postrust-core" }, { "affected_notes": [], "affected_ranges": [ "<= 2.4.0" ], "ecosystem": "rust", "fixed_versions": [ "2.4.1" ], "package_name": "postrust-server", "purl": "pkg:cargo/postrust-server" }, { "affected_notes": [], "affected_ranges": [ "<= 2.4.0" ], "ecosystem": "rust", "fixed_versions": [ "1.0.1" ], "package_name": "postrust-worker", "purl": "pkg:cargo/postrust-worker" } ], "cwes": [ 674 ], "cvss_score": 7.5, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "deterministic", "check": true, "check_confidence_basis": "differential", "exploit": false, "pipeline_minutes": 15.95904525, "t0_at": null, "signals": { "check": { "at": "2026-10-31T05:15:25.359431+00:00", "days": -1.069232823414352, "is_lower_bound": true, "measured_at": "2026-11-01T06:55:07.160334+00:00", "url": null }, "trigger_signal": { "at": "2026-10-30T18:28:05+00:00", "days": -1.5187740205324074, "is_lower_bound": true, "measured_at": "2026-11-01T06:55:07.160334+00:00", "url": "https://github.com/postrust/postrust/security/advisories/GHSA-cx7m-cfcg-xpp8" } } }
published 2026-10-31 04:59Z
last change 2026-11-01 06:51Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.