ETK-2026-3021Zero's internal tracking ID, independent of the CVE number.
waiting for further signalsZero needs more public information before it can validate it.description
Avo versions before 3.33.3 and 4.3.8 can fail to enforce authorization policies for updates, association views, charts, and some has_one operations. An authenticated Avo user may be able to read, modify, or detach records beyond the permissions intended by an application's policies when the application uses Avo policy-client authorization.
mitigation
Upgrade avo to 3.33.3 or 4.3.8. For Avo 3 installations using avo-pro or avo-advanced, update avo-pro, avo-advanced, avo-dashboards, avo-menu, and avo-dynamic_filters to 3.33.3 together with avo.
fixed in 3.33.3, 4.3.8
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-28 01:41Zghsa: trigger signal, started the run
this entry in the feed
GET /api/v1/feed/ETK-2026-3021
{ "etk_id": "ETK-2026-3021", "cve_id": null, "display_id": "ETK-2026-3021", "ghsa_id": "GHSA-5qcq-2vq9-62hj", "euvd_id": null, "status": "published", "anchor_state": "awaiting_cve", "title": "Authorization bypasses in Avo policy enforcement", "summary": "Avo versions before 3.33.3 and 4.3.8 can fail to enforce authorization policies for updates, association views, charts, and some has_one operations. An authenticated Avo user may be able to read, modify, or detach records beyond the permissions intended by an application's policies when the application uses Avo policy-client authorization.", "mitigation": "Upgrade avo to 3.33.3 or 4.3.8. For Avo 3 installations using avo-pro or avo-advanced, update avo-pro, avo-advanced, avo-dashboards, avo-menu, and avo-dynamic_filters to 3.33.3 together with avo.", "vendor": "rubygems", "product": "rubygems:avo", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 1.22.0, < 3.33.3" ], "ecosystem": "rubygems", "fixed_versions": [ "3.33.3" ], "package_name": "avo", "purl": "pkg:gem/avo" }, { "affected_notes": [], "affected_ranges": [ ">= 4.0.0.beta.1, < 4.3.8" ], "ecosystem": "rubygems", "fixed_versions": [ "4.3.8" ], "package_name": "avo", "purl": "pkg:gem/avo" } ], "cwes": [ 862 ], "cvss_score": 7.1, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 81.96154195, "t0_at": null, "signals": { "trigger_signal": { "at": "2026-10-28T01:41:32+00:00", "days": -2.1439804991435185, "is_lower_bound": true, "measured_at": "2026-10-30T05:08:51.947011+00:00", "url": "https://github.com/avo-hq/avo/security/advisories/GHSA-5qcq-2vq9-62hj" } } }
published 2026-10-30 00:01Z
last change 2026-10-30 05:07Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.