ETK-2026-2842Zero's internal tracking ID, independent of the CVE number.
waiting for further signalsZero needs more public information before it can validate it.description
ep_etherpad-lite before 3.3.3 can retain a pre-authentication session identifier after an SSO login. An attacker who can cause a victim's browser to use a session identifier known to the attacker may reuse it after the victim authenticates, potentially accessing the victim's account or administrator session. Exploitation requires a cookie-injection capability and a victim completing an SSO login.
mitigation
Upgrade ep_etherpad-lite to version 3.3.3 or later. Until upgraded, restrict SSO access and prevent untrusted parties from setting or injecting application session cookies.
fixed in 3.3.3
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-27 13:03Zghsa: trigger signal, started the run
- 2026-10-27 13:03Z
this entry in the feed
GET /api/v1/feed/ETK-2026-2842
{ "etk_id": "ETK-2026-2842", "cve_id": null, "display_id": "ETK-2026-2842", "ghsa_id": "GHSA-73h9-c5xp-gfg4", "euvd_id": null, "status": "published", "anchor_state": "awaiting_cve", "title": "Session fixation in ep_etherpad-lite SSO authentication", "summary": "ep_etherpad-lite before 3.3.3 can retain a pre-authentication session identifier after an SSO login. An attacker who can cause a victim's browser to use a session identifier known to the attacker may reuse it after the victim authenticates, potentially accessing the victim's account or administrator session. Exploitation requires a cookie-injection capability and a victim completing an SSO login.", "mitigation": "Upgrade ep_etherpad-lite to version 3.3.3 or later. Until upgraded, restrict SSO access and prevent untrusted parties from setting or injecting application session cookies.", "vendor": "npm", "product": "npm:ep_etherpad-lite", "affected": [ { "affected_notes": [], "affected_ranges": [ "<= 3.3.2" ], "ecosystem": "npm", "fixed_versions": [ "3.3.3" ], "package_name": "ep_etherpad-lite", "purl": "pkg:npm/ep_etherpad-lite" } ], "cwes": [ 384 ], "cvss_score": 7.5, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 23.777526683333335, "t0_at": null, "signals": { "public_poc": { "at": "2026-10-27T13:03:08+00:00", "days": -0.8833389530902778, "is_lower_bound": true, "measured_at": "2026-10-28T10:15:08.514640+00:00", "url": "https://github.com/ether/etherpad/security/advisories/GHSA-73h9-c5xp-gfg4" }, "trigger_signal": { "at": "2026-10-27T13:03:08+00:00", "days": -0.8833389530902778, "is_lower_bound": true, "measured_at": "2026-10-28T10:15:08.514640+00:00", "url": "https://github.com/ether/etherpad/security/advisories/GHSA-73h9-c5xp-gfg4" } } }
published 2026-10-28 07:47Z
last change 2026-10-28 10:05Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.