CVE-2026-95860
waiting for further signalsZero needs more public information before it can validate it.description
node-opcua 2.42.0 through versions before 2.180.0 may not enforce configured namespace-default role permissions for nodes without explicit per-node permissions. An unauthenticated network client could write eligible variables or invoke bound methods when a server relies on restrictive namespace defaults being inherited.
mitigation
Upgrade node-opcua to version 2.180.0. Until upgraded, assign explicit per-node permissions for sensitive nodes and restrict unauthenticated network access.
fixed in 2.180.0
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-11-03 20:11Zcve_org: trigger signal, started the run
this entry in the feed
GET /api/v1/feed/CVE-2026-95860
{ "etk_id": "ETK-2026-3406", "cve_id": "CVE-2026-95860", "display_id": "CVE-2026-95860", "ghsa_id": "GHSA-xggf-m53x-jc3f", "euvd_id": null, "status": "published", "anchor_state": "anchored", "title": "Namespace permission bypass in node-opcua", "summary": "node-opcua 2.42.0 through versions before 2.180.0 may not enforce configured namespace-default role permissions for nodes without explicit per-node permissions. An unauthenticated network client could write eligible variables or invoke bound methods when a server relies on restrictive namespace defaults being inherited.", "mitigation": "Upgrade node-opcua to version 2.180.0. Until upgraded, assign explicit per-node permissions for sensitive nodes and restrict unauthenticated network access.", "vendor": "node-opcua", "product": "node-opcua", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 2.42.0" ], "ecosystem": "npm", "fixed_versions": [ "2.180.0" ], "package_name": "node-opcua", "purl": "pkg:npm/node-opcua" }, { "affected_notes": [], "affected_ranges": [ ">= 2.42.0" ], "ecosystem": "npm", "fixed_versions": [ "2.180.0" ], "package_name": "node-opcua-address-space", "purl": "pkg:npm/node-opcua-address-space" }, { "affected_notes": [], "affected_ranges": [ ">= 2.42.0" ], "ecosystem": "npm", "fixed_versions": [ "2.180.0" ], "package_name": "node-opcua-server", "purl": "pkg:npm/node-opcua-server" } ], "cwes": [ 285 ], "cvss_score": 9.1, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 31.214615633333334, "t0_at": "2026-11-03T20:11:38.816000+00:00", "signals": { "trigger_signal": { "at": "2026-11-03T20:11:38.816000+00:00", "days": 0, "is_lower_bound": false, "measured_at": "2026-11-03T20:11:38.816000+00:00", "url": "https://www.cve.org/CVERecord?id=CVE-2026-95860" } } }
published 2026-11-03 20:48Z
last change 2026-11-03 22:03Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.