CVE-2026-87799
waiting for further signalsZero needs more public information before it can validate it.GHSA-fmc3-3cpq-6whr ↗EUVD-2026-88260 ↗
description
Canonical LXD migration receiving is affected by improper resolution of links in transferred instance or custom-volume data. An authenticated client permitted to create project resources, or an untrusted migration source, can cause attacker-selected files to be written on the target host with root privileges. Exposure requires accepting migrations or resource creation from such a principal.
mitigation
Upgrade LXD to 4.0.14, 5.0.10, 5.21.8, 6.9-bf243da, 6.10, or a later applicable release. Until upgraded, permit instance and custom-volume creation and migration only from trusted clients and source servers.
fixed in 4.0.14, 5.0.10, 5.21.8, 6.9-bf243da, 6.10
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-09-28 13:22Zghsa: trigger signal, started the run
- 2026-09-28 13:22Zcve.org record for CVE-2026-87799
this entry in the feed
GET /api/v1/feed/CVE-2026-87799
{ "etk_id": "ETK-2026-3104", "cve_id": "CVE-2026-87799", "display_id": "CVE-2026-87799", "ghsa_id": "GHSA-fmc3-3cpq-6whr", "euvd_id": "EUVD-2026-88260", "status": "published", "anchor_state": "anchored", "title": "Improper symlink resolution in LXD migration receive", "summary": "Canonical LXD migration receiving is affected by improper resolution of links in transferred instance or custom-volume data. An authenticated client permitted to create project resources, or an untrusted migration source, can cause attacker-selected files to be written on the target host with root privileges. Exposure requires accepting migrations or resource creation from such a principal.", "mitigation": "Upgrade LXD to 4.0.14, 5.0.10, 5.21.8, 6.9-bf243da, 6.10, or a later applicable release. Until upgraded, permit instance and custom-volume creation and migration only from trusted clients and source servers.", "vendor": "canonical", "product": "LXD", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 4.0" ], "ecosystem": null, "fixed_versions": [ "4.0.14", "5.0.10", "5.21.8", "6.9-bf243da", "6.10" ], "package_name": "lxd", "purl": null } ], "cwes": null, "cvss_score": 9.9, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 23.015727766666668, "t0_at": "2026-09-28T13:22:29.148000+00:00", "signals": { "trigger_signal": { "at": "2026-09-28T13:22:29.148000+00:00", "days": 0, "is_lower_bound": false, "measured_at": "2026-09-28T13:22:29.148000+00:00", "url": "https://github.com/canonical/lxd/security/advisories/GHSA-fmc3-3cpq-6whr" } } }
published 2026-10-30 19:00Z
last change 2026-10-30 21:11Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.