CVE-2026-87018
waiting for further signalsZero needs more public information before it can validate it.GHSA-qrxm-fqhp-jwvm ↗EUVD-2026-102318 ↗
description
Affected undici versions can exit the Node.js process when connecting to a malicious or compromised HTTPS service that performs a TLS 1.2 renegotiation with a mismatched hostname certificate. An attacker must control, or be able to alter, an HTTPS endpoint used by undici or global fetch(); the resulting process termination can interrupt ongoing work.
mitigation
Upgrade undici to 6.29.1, 7.30.1, or 8.12.2, as appropriate for your release line. Until upgraded, require TLS 1.3 for outbound undici connections where destination compatibility permits.
fixed in 6.29.1, 7.30.1, 8.12.2
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-15 18:38Zghsa: trigger signal, started the run
- 2026-10-15 18:38Zcve.org record for CVE-2026-87018
this entry in the feed
GET /api/v1/feed/CVE-2026-87018
{ "etk_id": "ETK-2026-2621", "cve_id": "CVE-2026-87018", "display_id": "CVE-2026-87018", "ghsa_id": "GHSA-qrxm-fqhp-jwvm", "euvd_id": "EUVD-2026-102318", "status": "published", "anchor_state": "anchored", "title": "TLS renegotiation denial of service in undici", "summary": "Affected undici versions can exit the Node.js process when connecting to a malicious or compromised HTTPS service that performs a TLS 1.2 renegotiation with a mismatched hostname certificate. An attacker must control, or be able to alter, an HTTPS endpoint used by undici or global fetch(); the resulting process termination can interrupt ongoing work.", "mitigation": "Upgrade undici to 6.29.1, 7.30.1, or 8.12.2, as appropriate for your release line. Until upgraded, require TLS 1.3 for outbound undici connections where destination compatibility permits.", "vendor": "nodejs", "product": "npm:undici", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 4.2.1, < 6.29.1" ], "ecosystem": "npm", "fixed_versions": [ "6.29.1" ], "package_name": "undici", "purl": "pkg:npm/undici" }, { "affected_notes": [], "affected_ranges": [ ">= 7.0.0, < 7.30.1" ], "ecosystem": "npm", "fixed_versions": [ "7.30.1" ], "package_name": "undici", "purl": "pkg:npm/undici" }, { "affected_notes": [], "affected_ranges": [ ">= 8.0.0, < 8.12.2" ], "ecosystem": "npm", "fixed_versions": [ "8.12.2" ], "package_name": "undici", "purl": "pkg:npm/undici" } ], "cwes": [ 248 ], "cvss_score": 7.5, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 14.80726165, "t0_at": "2026-10-15T18:38:25.613000+00:00", "signals": { "trigger_signal": { "at": "2026-10-15T18:38:25.613000+00:00", "days": 0, "is_lower_bound": false, "measured_at": "2026-10-15T18:38:25.613000+00:00", "url": "https://github.com/nodejs/undici/security/advisories/GHSA-qrxm-fqhp-jwvm" } } }
published 2026-10-26 03:40Z
last change 2026-10-26 08:00Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.