CVE-2026-119190
waiting for further signalsZero needs more public information before it can validate it.GHSA-5x38-2vff-x55p ↗EUVD-2026-113347 ↗
description
node-forge versions before 1.4.1 may misinterpret obsolete X.509 extension identifiers when validating certificate chains. An attacker with a suitably issued certificate from an application-trusted CA that preserves supplied extensions may have that certificate accepted as a CA and use it to issue certificates for arbitrary identities.
mitigation
Upgrade the npm node-forge package to version 1.4.1 or later. Until then, reject non-leaf certificates unless the standard basicConstraints extension (OID 2.5.29.19) explicitly marks them as CA certificates.
fixed in 1.4.1
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-27 04:57Zghsa: trigger signal, started the run
- 2026-10-29 19:25Zcve.org record for CVE-2026-119190
this entry in the feed
GET /api/v1/feed/CVE-2026-119190
{ "etk_id": "ETK-2026-2731", "cve_id": "CVE-2026-119190", "display_id": "CVE-2026-119190", "ghsa_id": "GHSA-5x38-2vff-x55p", "euvd_id": "EUVD-2026-113347", "status": "published", "anchor_state": "anchored", "title": "Certificate constraints validation bypass in node-forge", "summary": "node-forge versions before 1.4.1 may misinterpret obsolete X.509 extension identifiers when validating certificate chains. An attacker with a suitably issued certificate from an application-trusted CA that preserves supplied extensions may have that certificate accepted as a CA and use it to issue certificates for arbitrary identities.", "mitigation": "Upgrade the npm node-forge package to version 1.4.1 or later. Until then, reject non-leaf certificates unless the standard basicConstraints extension (OID 2.5.29.19) explicitly marks them as CA certificates.", "vendor": "npm", "product": "npm:node-forge", "affected": [ { "affected_notes": [], "affected_ranges": [ "<= 1.4.0" ], "ecosystem": "npm", "fixed_versions": [ "1.4.1" ], "package_name": "node-forge", "purl": "pkg:npm/node-forge" } ], "cwes": [ 295 ], "cvss_score": 7.4, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 17.950349683333332, "t0_at": "2026-10-29T19:25:09.677000+00:00", "signals": { "trigger_signal": { "at": "2026-10-27T04:57:26+00:00", "days": -2.6025888541666666, "is_lower_bound": false, "measured_at": "2026-10-29T19:25:09.677000+00:00", "url": "https://github.com/digitalbazaar/forge/security/advisories/GHSA-5x38-2vff-x55p" } } }
published 2026-10-27 06:06Z
last change 2026-10-29 23:36Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.