CVE-2026-118477
validatedZero produced an exploit or a check.GHSA-5r57-pmj5-8h6f ↗EUVD-2026-112022 ↗
description
EISGE Kalifast's Git remote configuration feature is affected by an OS command-injection flaw. An attacker who can authenticate, including through self-registration where enabled, may run commands on the server with the web-service account's permissions.
mitigation
Upgrade EISGE Kalifast to version 2026061802 or later. Until upgrading, disable or restrict access to Git remote configuration and review whether untrusted users can register accounts.
fixed in 2026.02.1
outcome
Contextual check: a technique exists and was validated, but no deterministic check could cover this one.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-28 11:09Zghsa: trigger signal, started the run
- 2026-10-28 11:09Zcve.org record for CVE-2026-118477
this entry in the feed
GET /api/v1/feed/CVE-2026-118477
{ "etk_id": "ETK-2026-2865", "cve_id": "CVE-2026-118477", "display_id": "CVE-2026-118477", "ghsa_id": "GHSA-5r57-pmj5-8h6f", "euvd_id": "EUVD-2026-112022", "status": "published", "anchor_state": "anchored", "title": "OS command injection in EISGE Kalifast Git remote configuration", "summary": "EISGE Kalifast's Git remote configuration feature is affected by an OS command-injection flaw. An attacker who can authenticate, including through self-registration where enabled, may run commands on the server with the web-service account's permissions.", "mitigation": "Upgrade EISGE Kalifast to version 2026061802 or later. Until upgrading, disable or restrict access to Git remote configuration and review whether untrusted users can register accounts.", "vendor": "EISGE", "product": "Kalifast", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 0, < 2026.02.1" ], "ecosystem": null, "fixed_versions": [ "2026.02.1" ], "package_name": "Kalifast", "purl": null } ], "cwes": null, "cvss_score": 9.8, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": true, "check_confidence_basis": "assessed", "exploit": false, "pipeline_minutes": 23.86641765, "t0_at": "2026-10-28T11:09:58.882000+00:00", "signals": { "check": { "at": "2026-10-28T13:11:48.584208+00:00", "days": 0.08460303481481482, "is_lower_bound": false, "measured_at": "2026-10-28T11:09:58.882000+00:00", "url": null }, "trigger_signal": { "at": "2026-10-28T11:09:58.882000+00:00", "days": 0, "is_lower_bound": false, "measured_at": "2026-10-28T11:09:58.882000+00:00", "url": "https://github.com/advisories/GHSA-5r57-pmj5-8h6f" } } }
published 2026-10-28 12:47Z
last change 2026-10-28 16:08Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.