CVE-2026-115907
waiting for further signalsZero needs more public information before it can validate it.GHSA-9hj8-73fh-9963 ↗EUVD-2026-109984 ↗
description
Rust applications using the zip crate with the legacy-zip feature enabled are affected when they extract attacker-controlled ZIP archives through ZipArchive::extract(). A crafted archive can trigger an unhandled panic and terminate the archive-processing process. Exploitation requires an application to enable legacy ZIP codecs and process untrusted archives with the affected extraction API.
mitigation
Upgrade the Rust zip crate to version 9.0.0 or later. Until upgraded, disable the legacy-zip feature and avoid extracting untrusted archives through the affected API.
fixed in 9.0.0
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-10-26 16:32Zghsa: trigger signal, started the run
- 2026-10-26 16:32Zpublic poc, published 2026-10-22 19:31Z
- 2026-10-26 16:32Zcve.org record for CVE-2026-115907
this entry in the feed
GET /api/v1/feed/CVE-2026-115907
{ "etk_id": "ETK-2026-2717", "cve_id": "CVE-2026-115907", "display_id": "CVE-2026-115907", "ghsa_id": "GHSA-9hj8-73fh-9963", "euvd_id": "EUVD-2026-109984", "status": "published", "anchor_state": "anchored", "title": "Denial of service in Rust zip legacy ZIP extraction", "summary": "Rust applications using the `zip` crate with the `legacy-zip` feature enabled are affected when they extract attacker-controlled ZIP archives through `ZipArchive::extract()`. A crafted archive can trigger an unhandled panic and terminate the archive-processing process. Exploitation requires an application to enable legacy ZIP codecs and process untrusted archives with the affected extraction API.", "mitigation": "Upgrade the Rust `zip` crate to version 9.0.0 or later. Until upgraded, disable the `legacy-zip` feature and avoid extracting untrusted archives through the affected API.", "vendor": "rust", "product": "rust:zip", "affected": [ { "affected_notes": [], "affected_ranges": [ ">= 5.1.0" ], "ecosystem": "rust", "fixed_versions": [ "9.0.0" ], "package_name": "zip", "purl": "pkg:cargo/zip" } ], "cwes": [ 400 ], "cvss_score": 7.5, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 29.679922366666666, "t0_at": "2026-10-26T16:32:15.373000+00:00", "signals": { "public_poc": { "at": "2026-10-22T19:31:42+00:00", "days": -3.875386261574074, "is_lower_bound": false, "measured_at": "2026-10-26T16:32:15.373000+00:00", "url": "https://github.com/zip-rs/zip2/security/advisories/GHSA-9hj8-73fh-9963" }, "trigger_signal": { "at": "2026-10-26T16:32:15.373000+00:00", "days": 0, "is_lower_bound": false, "measured_at": "2026-10-26T16:32:15.373000+00:00", "url": "https://github.com/zip-rs/zip2/security/advisories/GHSA-9hj8-73fh-9963" } } }
published 2026-10-27 02:32Z
last change 2026-10-27 06:57Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.