CVE-2026-103002
waiting for further signalsZero needs more public information before it can validate it.GHSA-3hch-x692-6qj3 ↗EUVD-2026-117177 ↗
description
gpustack versions 2.2.0 through before 2.2.2 do not properly authorize some non-administrator requests sent through its Kubernetes API proxy. An authenticated user may access Kubernetes resources or alter workloads within the permissions of a reachable worker's ServiceAccount; exploitation requires a Kubernetes-provider cluster with a reachable worker.
mitigation
Upgrade the gpustack package to version 2.2.2. Until the upgrade is complete, limit GPUStack access to trusted administrator accounts.
fixed in 2.2.2
outcome
Contextual, not validated: no deterministic check could cover this one, and no technique passed our review.
source signals
Public signals that triggered or updated the pipeline. These are inputs for the deltas above.
- 2026-11-04 21:33Zghsa: trigger signal, started the run
- 2026-11-04 21:33Zcve.org record for CVE-2026-103002
this entry in the feed
GET /api/v1/feed/CVE-2026-103002
{ "etk_id": "ETK-2026-3558", "cve_id": "CVE-2026-103002", "display_id": "CVE-2026-103002", "ghsa_id": "GHSA-3hch-x692-6qj3", "euvd_id": "EUVD-2026-117177", "status": "published", "anchor_state": "anchored", "title": "Missing Kubernetes proxy authorization in gpustack", "summary": "gpustack versions 2.2.0 through before 2.2.2 do not properly authorize some non-administrator requests sent through its Kubernetes API proxy. An authenticated user may access Kubernetes resources or alter workloads within the permissions of a reachable worker's ServiceAccount; exploitation requires a Kubernetes-provider cluster with a reachable worker.", "mitigation": "Upgrade the gpustack package to version 2.2.2. Until the upgrade is complete, limit GPUStack access to trusted administrator accounts.", "vendor": "pip", "product": "pip:gpustack", "affected": [ { "affected_notes": [], "affected_ranges": [ ">=2.2.0", "<2.2.2" ], "ecosystem": "pip", "fixed_versions": [ "2.2.2" ], "package_name": "gpustack", "purl": "pkg:pypi/gpustack" } ], "cwes": [ 862 ], "cvss_score": 8.8, "cvss_src": "cna_vendor", "cvss_vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H", "epss_score": null, "epss_percentile": null, "epss_asof": null, "automation": "contextual", "check": false, "check_confidence_basis": null, "exploit": false, "pipeline_minutes": 28.264568916666665, "t0_at": "2026-11-04T21:33:41.176000+00:00", "signals": { "trigger_signal": { "at": "2026-11-04T21:33:41.176000+00:00", "days": 0, "is_lower_bound": false, "measured_at": "2026-11-04T21:33:41.176000+00:00", "url": "https://github.com/gpustack/gpustack/security/advisories/GHSA-3hch-x692-6qj3" } } }
published 2026-11-04 23:59Z
last change 2026-11-05 00:45Z
Need the technical details behind an entry?
Every entry here shows what we attempted and when. The technical details, the generated exploit that fired it and the evidence behind the verdict are not public. Tell us about your use case and we’ll get back to you about extended API access.